Process Hacker and Windows discussion

 
ccppuu
Member
Posts: 51

3.0.5311.784 no plugin

11 Jul 2017, 06:09

3.0.5311.784 build portable not load plugins.
 
User avatar
dmex
Admin
Posts: 1258
Location: Australia

Re: 3.0.5311.784 no plugin

11 Jul 2017, 07:51

You sure you're using the correct paths and settings?
 
ccppuu
Member
Posts: 51

Re: 3.0.5311.784 no plugin

11 Jul 2017, 07:58

How check it.
I have replaced previuos exe in the folder only.
Same problem if i delete "ProcessHacker.exe.settings.xml" in folder application.
 
User avatar
diversenok
Member
Posts: 25
OS: Windows 7 x64
Location: Source Code
Contact:

Re: 3.0.5311.784 no plugin

11 Jul 2017, 08:06

I had similar problem when messed up with plugins files. Try to disable plugins in Options → General, restart PH, and enable them again.
 
ccppuu
Member
Posts: 51

Re: 3.0.5311.784 no plugin

11 Jul 2017, 08:15

disable plugins and enable them again not solve for me.
Also, when PH restart it have error:
Impossible to find \Device\ImDisk0\ProcessHacker\ProcessHacker.exe
If i move PH from virtual device to phisical device and disable plugins and enable them again then it work.
Problem is virtual device.
 
User avatar
diversenok
Member
Posts: 25
OS: Windows 7 x64
Location: Source Code
Contact:

Re: 3.0.5311.784 no plugin

11 Jul 2017, 08:39

I was able to reproduce this behavior. I created Ram disk (R:\) and launched PH from it's root folder. So, what i get:

Image file name: \Device\ImDisk0\ProcessHacker.exe
Command line: "R:\ProcessHacker.exe"

I figured that Process Hacker tries to find plugins in "R:\Device\ImDisk0\plugins\". It combines image file name, drive, and \plugins\ sub-folder. And it fails.

UPD:
I was not able to force windows to use "R:\ProcessHacker.exe" as image file name. For you it's easier to put plugins in the place, where PH searches for them. It will work ;)
 
User avatar
dmex
Admin
Posts: 1258
Location: Australia

Re: 3.0.5311.784 no plugin

11 Jul 2017, 11:48

Fixed in #f0c02aa :thumbup:
 
ccppuu
Member
Posts: 51

Re: 3.0.5311.784 no plugin

11 Jul 2017, 12:01

Confirm fix, ty.

Who is online

Users browsing this forum: No registered users and 2 guests